Follow

When I try and update QuickTech PRO / Premium USB drive it gives me an error

Question:

When I try and update the USB drive it gives me an error (please see below in the image).

QTP Updater Error

 

Solution:

Make sure your Windows machine meets the following requirements and has the following packages installed:

Requirements:
Windows 7 / Windows 8 / Windows 10 64 bit OS

*This update will only work on 64 bit platforms*

Must be a USB 2.0 slot.
Verify that no other USB device drives are plugged into the system.
Verify that you have the following .NET Framework installed, you can use a tool called .NET Version Detector that is freely available on the web (I’ve linked the software below):
.NET 2.0 Service Pack 2
.NET 4.5.1
Visual C++ Redistributable 2008 x64

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.